[ipxe-devel] SOLVED, but open questions [was Re: build error for ipxe.efi]

Michael Brown mcb30 at ipxe.org
Wed Jun 28 13:50:12 UTC 2017

On 28/06/17 14:44, Oliver Rath new wrote:
> Enabling "IPXE_CMD" resulted in build fail of ipxe.efi binary (what is 
> it good for?).

Is that a typo?  There is no "IPXE_CMD" anywhere in the codebase.

> Interesting point: Starting a "config" in a shell result in correct 
> values, but it was not possible to exit the config command via ctrl-x.

Some UEFI keyboard drivers don't handle the Ctrl key, so pressing 
"Ctrl-X" appears to iPXE as just "X".  You can work around this by 
pressing "ESC" "X" instead:


> Imho uefi bios needs a correct "fingerprint" of the binary, which can be 
> validated in UEFI-Bios. I didnt change anything in my uefi-bios and 
> booting worked fine (!), but very slowly at the beginning. After 
> chainloading some scripts it had the old speed.
> How does the UEFI-bios know, that the image is correct??? Has ipxe.efi 
> signed with a global uefi key, i.e. from microsoft?
> What magic things are happening here?

You can turn on Secure Boot, which would fail to boot your iPXE binary 
unless you had signed it with a key accepted by the UEFI BIOS.  The fact 
that your home-built iPXE binary is accepted indicates that you do not 
have Secure Boot enabled.

Some UEFI console drivers are very slow at printing text.  This can lead 
to a visible teletype effect when large blocks of text are being 
printed, such as the iPXE startup banner.


More information about the ipxe-devel mailing list