[ipxe-devel] SOLVED, but open questions [was Re: build error for ipxe.efi]

Oliver Rath new rath at mglug.de
Wed Jun 28 13:44:28 UTC 2017

Hi list,

building ipxe.efi from scratch worked. I also was able to enhance the
command set like console, ping, etc.

Enabling "IPXE_CMD" resulted in build fail of ipxe.efi binary (what is
it good for?).

Interesting point: Starting a "config" in a shell result in correct
values, but it was not possible to exit the config command via ctrl-x.

Imho uefi bios needs a correct "fingerprint" of the binary, which can be
validated in UEFI-Bios. I didnt change anything in my uefi-bios and
booting worked fine (!), but very slowly at the beginning. After
chainloading some scripts it had the old speed.

How does the UEFI-bios know, that the image is correct??? Has ipxe.efi
signed with a global uefi key, i.e. from microsoft?

What magic things are happening here?



On 27.06.2017 18:11, Oliver Rath new wrote:
> Hi list,
> ive got an build-error for ipxe.efi. Please see attachment for log. Ive
> built it with
> oliver at w541:~/gits/ipxe/src$ make -j12 bin-x86_64-efi/ipxe.efi >&
> /home/oliver/ipxe.efi.debug.txt
> with the sources of today.
> in ipxe sources Ive included in src/config/local the files general.h and
> console.h (see attachment, too)
> Whats wrong here?
> Tfh!
> Oliver
> _______________________________________________
> ipxe-devel mailing list
> ipxe-devel at lists.ipxe.org
> https://lists.ipxe.org/mailman/listinfo.cgi/ipxe-devel

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ipxe.org/pipermail/ipxe-devel/attachments/20170628/d9fcadb4/attachment.htm>

More information about the ipxe-devel mailing list