[ipxe-devel] UEFI wimboot

Levente LEVAI levail at aviatronic.hu
Fri Sep 5 09:21:46 BST 2014


Dear Michael,

Thank you for your help, with the latest commit (I pulled commit
895d73f383f5af003ab2e5105e54c9a90b224e77 today morning) I was able to 
get things working.

There was one catch though, and this may be related to Nicolas Cattie's
problem (I had the same symptoms, at least).

I found that when snponly.efi is fetched via IPv6 current version of 
ipxe has a problem finding the SNP device (ifstat returned nothing). 
Building with the DEBUG switches you suggested to Nicolas revealed
that ipxe finds an SNP device but drops it as being different
from the chainloading device. My workaround was that I commented out

     rc = -ENOTTY;
     goto err_not_snponly;

on line 77 and 78 of drivers/net/efi/snponly.c (and the goto label 
err_not_snponly: on line 86 to get the code compile). With these crude
modifications things worked both in IPv6 and IPv4 on the computer I
used, a TOSHIBA NB10.

I also tried (on the same computer) the unmodified source with manually
selecting IPv4 boot in the firmware boot menu. This setup also worked 
for me.

Do you have some suggestions what the proper solution would be?

Best regards,
Levente


More information about the ipxe-devel mailing list