[ipxe-devel] UEFI wimboot

Michael Brown mcb30 at ipxe.org
Thu Sep 18 14:49:46 BST 2014


On 05/09/14 09:21, Levente LEVAI wrote:
> I found that when snponly.efi is fetched via IPv6 current version of
> ipxe has a problem finding the SNP device (ifstat returned nothing).
> Building with the DEBUG switches you suggested to Nicolas revealed
> that ipxe finds an SNP device but drops it as being different
> from the chainloading device. My workaround was that I commented out
>
>      rc = -ENOTTY;
>      goto err_not_snponly;
>
> on line 77 and 78 of drivers/net/efi/snponly.c (and the goto label
> err_not_snponly: on line 86 to get the code compile). With these crude
> modifications things worked both in IPv6 and IPv4 on the computer I
> used, a TOSHIBA NB10.
>
> I also tried (on the same computer) the unmodified source with manually
> selecting IPv4 boot in the firmware boot menu. This setup also worked
> for me.
>
> Do you have some suggestions what the proper solution would be?

The easiest fix will be to use snp.efi instead of snponly.efi: the only 
difference is that snponly attempts to bind only to the chainloaded 
device while snp.efi will bind to any available SNP device.

I'm not sure what the proper solution is for snponly.efi in that 
situation.  It seems to be non-trivial to determine which is the real 
underlying SNP device.

Michael


More information about the ipxe-devel mailing list