[ipxe-devel] Black screen on Intel NUC after wimboot

Michael Brown mcb30 at ipxe.org
Thu Nov 6 14:11:37 UTC 2014

On 06/11/14 10:22, Ivan Krutskikh wrote:
> Thanks for the IPXE project. So far I had no problems with it in various
> san boot scenarios.
> Until I tried http://ipxe.org/howto/winpe deploy scenario with a couple
> of first generation intel nuc pc's
> (http://ark.intel.com/products/71484/Intel-NUC-Kit-DCCP847DY).
> I launch the latest ipxe.lkrn from syslinux on a local usb key:
> label wimboot
>      kernel /boot/ipxe.lkrn
>      append initrd=/boot/boot.ipxe
> boot.ipxe :
> #!ipxe
> dhcp
> set netX/gateway
> sanhook  iscsi:
> kernel
> initrd BCD
> initrd boot.sdi
> initrd boot.wim
> boot
> This boot option worked on almost any other pc in my office, but on
> nuc's it downloads all the defined images, flashes black screen and reboots.
> What am I doing wrong here and what can be done to get it fixed?

I would suggest trying to simplify the setup to try to narrow down what 
might be causing the problem.

For example, you could try eliminating syslinux and iSCSI by building 
bin/ipxe.usb with an embedded script containing

   initrd BCD
   initrd boot.sdi
   initrd boot.wim

Also, are you using the current version of wimboot (v2.3.0)?


More information about the ipxe-devel mailing list