[ipxe-devel] Image Load is gone?

Michael Brown mbrown at fensystems.co.uk
Wed Mar 27 22:24:02 UTC 2013

On Tuesday 26 Mar 2013 16:32:55 Duane Voth wrote:
> The same error occurs regardless of what .efi I try, driver or app, so I'm
> probably off in the weeds somewhere.  2c04803b points to
> ipxe/src/image/efi_image.c:138  which suggests a problem finding the SNP
> device.  snponly has worked on this box for a long time...

OK, that makes a lot more sense than the original problem report.

From a quick look at the code, it looks as though efi_snp_probe() will skip 
non-PCI devices.  iPXE will therefore not create an SNP device when using 
snponly.  Since iPXE now requires some kind of parent device when loading an 
image (in order to construct a device path for finding the other images), this 
will cause image loading to fail under snponly.efi.

It's debatable whether or not iPXE should create its own SNP device on top of 
an existing SNP device discovered via snponly.  Doing so would simplify our 
internal logic, and would be consistent with the way we handle things via 
undionly; we create and expose our own PXE+UNDI API even though an underlying 
UNDI API already exists.  On the other hand, it feels as though it may be 
adding unnecessary complexity to have an SNP device on top of an existing SNP 

Still thinking about the best way to fix this.


More information about the ipxe-devel mailing list