[ipxe-devel] Image Load is gone?

Duane Voth duanev at gmail.com
Tue Mar 26 16:32:55 UTC 2013

Yes, this should have nothing to do with driver vs. app ...

To make sure I'm not introducing something odd I checked out a pristine
tree this morning and built snponly.efi.  But I can't even imgexec / chain
/ boot a shell

$ cd ipxe/src
$ make bin-x86_64-efi/snponly.efi
$ cp bin-x86_64-efi/snponly.efi /tftpboot

(reboot Dell T620 in uefi mode)
iPXE 1.0.0+ (9f75) --
Features: HTTP DNS TFTP EFI Menu
iPXE> dhcp
DHCP (net0 ....) .... ok
iPXE> imgfetch tftp://
tftp:// ok
iPXE> imgstat
shell.efi : 760928 bytes
iPXE> imgexec shell.efi
Could not boot: No such device (http://ipxe.org/2c04803b)

The same error occurs regardless of what .efi I try, driver or app, so I'm
probably off in the weeds somewhere.  2c04803b points to
ipxe/src/image/efi_image.c:138  which suggests a problem finding the SNP
device.  snponly has worked on this box for a long time...
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ipxe.org/pipermail/ipxe-devel/attachments/20130326/f14ed49a/attachment.htm>

More information about the ipxe-devel mailing list