[ipxe-devel] Booting from local disk on HP ProLiant machines

Christoph Schug chris+ipxe-devel at schug.net
Mon Jan 7 14:19:54 GMT 2013


On 2013-01-07 12:38, Matthew Helton wrote:
> Have you updated te firmware on the NIC?

Right now I have to say "no". I have no idea about the history of those 
machines and it is not so easy to extract the firmware revision level 
without those tools from HP. Unfortunately this hardware is not 
supported anymore by HP's current tools. Also did not find anything 
suitable in their firmware catalog file, 
ftp://ftp.hp.com/pub/softlib/software2/COL3293/catalog.xml. The most 
recent firmware package I found so far on the HP web site is apparently 
only supposed to run on very ancient Linux versions. I tried to make it 
work by supplying all required 32 bit compat libs matching the .so 
revision, but still the thing just segfaults.

Nevertheless I don't really think (!) that the problem is related to 
the NIC firmware as there are just too many reports on the net (also for 
the syslinux and gPXE project) that the HP BIOS is flawed like hell. But 
all of those reports are quite dated and not really related to iPXE. 
E.g., http://comments.gmane.org/gmane.network.etherboot.user/6515 states 
...

"This may be a known bug with HP BIOSes (which has allegedly been fixed 
in
HP's BIOS source tree), in which the INT 18 call to boot the next 
device
relies upon state stored somewhere in the 1000:xxxx segment.  Since 
this
segment gets overwritten before gPXE even starts executing, there's 
nothing
we can do to work around the problem if this is the case."

I don't know if that and other information in this thread makes sense 
to anybody. I am afraid that most of the iPXE/BIOS internals are just 
too low-level for me ;) but I would be more than happy to provide debug 
information and try patches.

Of course I also tried to build the bin/undionly.kkpxe (mentioned in 
the same post as the quote above) of iPXE (BTW, what is actually the 
main difference between all those .kpxe, .kkpxe, .kkkpxe etc.?) to see 
if the fix is still working and potentially was taken over from gPXE to 
iPXE, but the result is no different. Either it is not fixed in iPXE or 
the fix is broken or was highly specific to a certain hardware/firmware.

I was just curious if someone is aware of a workaround which just works 
or at least someone can confirm that it isn't an issue for him/her with 
some older ProLiant hardware (G5 and older) to boot from local disk per 
iPXE.

Christoph



More information about the ipxe-devel mailing list