[ipxe-devel] Issues installing Windows 7 to iSCSI with iPXE

Steve Cross hairlesshobo at stevecross.org
Thu Dec 27 01:48:55 UTC 2012

Hello everyone,

I am currently working on a proof of concept diskless Windows 7 HTPC
client setup. I am preparing for when I pick up a couple Intel NUC
units to replace my current full size HTPC clients.

I am chainloading undionly.kpxe from DHCP, and then I have my config
file as follows (ip addressed and iSCSI target changed):

sanboot --keep iscsi: ||
set arch x86
kernel wimboot
initrd winpe/${arch}/ISO/bootmgr       bootmgr
initrd winpe/${arch}/ISO/boot/bcd      BCD
initrd winpe/${arch}/ISO/boot/boot.sdi boot.sdi
initrd winpe/${arch}/winpe.wim         boot.wim

I have the "set arch x86" because I have found that with my copy of
Windows 7, I ALWAYS have to load the x86 WinPE in order for my
setup.exe to load.

iPXE will mount my iSCSI disk (I can see the connection on the server
side), attempt to boot, fail (because the disc is empty), and then
pass on to loading WinPE just as I would expect. The problem is that
once WinPE loads, it can no longer see the iSCSI disc. I have noticed
that while WinPE is loading, the iSCSI connection is lost.

Just for kicks, I modified my WinPE to support the Windows iSCSI
initiator, and after starting the service and launching iscsicpl, it
shows that the iSCSI disc that iPXE loaded is "reconnecting." I have
let it sit there and I have tried messing with the settings, and
nothing has worked. If I disconnect and reconnect it, then when I try
to install Windows, it says something along the lines of "I won't
install because your computer can't boot to this disc." This leads me
to believe that because of the disconnect/reconnect that the iBFT is
cleared out and negates the whole process.

Anybody got any ideas of things to try? I know this has to be
possible, but I can't seem to figure out what I am missing. Please let
me know if I forgot any important information.

Any help is greatly appreciated!


More information about the ipxe-devel mailing list