[ipxe-devel] Issues installing Windows 7 to iSCSI with iPXE

Robin Smidsrød robin at smidsrod.no
Mon Dec 31 13:47:26 UTC 2012

On 27.12.2012 02:48, Steve Cross wrote:
> #!ipxe
> sanboot --keep iscsi: ||
> set arch x86
> kernel wimboot
> initrd winpe/${arch}/ISO/bootmgr       bootmgr
> initrd winpe/${arch}/ISO/boot/bcd      BCD
> initrd winpe/${arch}/ISO/boot/boot.sdi boot.sdi
> initrd winpe/${arch}/winpe.wim         boot.wim
> boot

This does seem to be accurate. Nothing wrong here, as far as I can tell.

> I have the "set arch x86" because I have found that with my copy of
> Windows 7, I ALWAYS have to load the x86 WinPE in order for my
> setup.exe to load.

When you boot the Windows 7 installer from traditional CD, are you also
limited to only being able to use the x86 installer, or does x64 work?
If so, your computer might have problems running 64-bit software in general.

> iPXE will mount my iSCSI disk (I can see the connection on the server
> side), attempt to boot, fail (because the disc is empty), and then
> pass on to loading WinPE just as I would expect. The problem is that
> once WinPE loads, it can no longer see the iSCSI disc. I have noticed
> that while WinPE is loading, the iSCSI connection is lost.

This is completely normal. Once the Windows kernel takes over, iPXE is
no longer in control, and the iSCSI connection iPXE established is lost.
The iBFT generated by iPXE is there to inform Windows' iSCSI initiator
(client) that it should re-establish the connection once it's booted and

> Just for kicks, I modified my WinPE to support the Windows iSCSI
> initiator, and after starting the service and launching iscsicpl, it
> shows that the iSCSI disc that iPXE loaded is "reconnecting." I have
> let it sit there and I have tried messing with the settings, and
> nothing has worked. If I disconnect and reconnect it, then when I try
> to install Windows, it says something along the lines of "I won't
> install because your computer can't boot to this disc." This leads me
> to believe that because of the disconnect/reconnect that the iBFT is
> cleared out and negates the whole process.

If you boot up WinPE, you can press Shift-F10 to get a command shell
when the Windows installer has started. You can then run ipconfig to
ensure you have IP connectivity, and if you can ping other hosts, run
diskpart and see if your iSCSI volume is visible. If it is not visible,
most likely your WinPE doesn't support iSCSI boot, or you have some
network connectivity issue. If your iSCSI volume is listed among the
disks available, then in theory you should be able to see it in the
Windows installer and you should be able to partition and format it.
Though, a lot of people, me included, have problems that Windows just
forcibly refuses to accept that iSCSI disk as a valid installation
target, even though it is listed among the disks available. You get some
kind of stupid error message saying that this drive can't be verified as
bootable, so it refuses to install to it. I've heard reports that some
people say that if you partition the drive during the first run of the
installer, and then reboot and try again without partitioning, it might
work. I have not personally had luck with this approach, though.

Also, as mentioned here,
, you should pay attention to those two windows 7 setup log files that
contain information about the setup process:


When you're in the installer, I'm not sure if they are on the C drive or
the X drive. Try either one.

Hope this has given you a bit more insight.

-- Robin

More information about the ipxe-devel mailing list