[ipxe-devel] 486 with a Realtek 8139

Christian Iwata Nilsson nikize at gmail.com
Tue May 4 22:55:04 UTC 2021

On Wed, 5 May 2021, 00:28 Nikolai Zhubr, <n-a-zhubr at yandex.ru> wrote:

> Hi all,
> I'm having some trouble getting a Realtek 8139 card to boot successfully
> on a 486 box.
> Long ago I made an rtl8139 rom using Etherboot project and flashed it
> into a number of EEPROM chips. I found them working fine with all
> systems I tried starting Pentium1. However, 486s had problems.
> Basically, pxelinux failed to run somehow, whereas if using Realtek's
> official ROM blob, pxelinux started successfully. Now I'm trying to
> workaround/fix/understand the issue.
> My new idea was to chainload most current 8139 native image built from
> iPXE to see if it runs well on 486. Unfortunately, it does not:
> ========= Screenshot ==========
> Loading ...(PXE)............................done
> PXE->EB: !PXE at 9F40:0000, entry point at 9F40:0680
> UNDI code segment 9F40:0AAD, data segment 9E40:1000 (633-640kB)
> UNDI device is PCI 00:0E.0, type Etherboot (workaround enabled)
> 640kB free base memory after PXE unload
> (nothing happens after that line, like completely hanging)
> ===============================
> Supposedly there should not be any Pentium+ dependancies, right?
> Any other hints before I start digging through?
> Thank you,
> Regards,
> Nikolai

Have you tried any build with #undef TIVOLI_VMM_WORKAROUND?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ipxe.org/pipermail/ipxe-devel/attachments/20210505/ddc20362/attachment.htm>

More information about the ipxe-devel mailing list