[ipxe-devel] Desperately need help on booting Windows 10 from iSCSI

Qing Zheng qizheng at nvidia.com
Fri Jun 28 07:37:17 UTC 2019

Hi Johannes,

  I checked both index1 and index2 of Windows 10 boot.wim as well as install.wim, e1i65x64.sys is not in any of  the driver stores. During iSCSI boot somehow Windows decided to download and install it (device driver plug-and-play?). It's BootFlags is set to 3. The same as the actual driver e1i63x64.sys that is being used. (e1i63x64.sys is in the driver stores of both boot.wim and install.wim). From the device manager I tried to update the driver to the latest one which is e1d65x64.sys. I injected the latest driver e1d65x64.sys into both boot.wim and install.wim, hope Windows can pick up the latest one. However, it is still complaining that e1i65x64.sys is not signed.

  I tried to use a 10G card instead of the 1G card and no luck as well. The actual driver used by the 10G card is ixs65x64.sys, however, during iSCSI boot Windows is complaining that ixi65x64.sys is not signed. If I install on a local disk, no problem at all.

  Both e1i65x64.sys and ixi65x64.sys are not available in Intel network adapters for Windows 10 (https://downloadcenter.intel.com/download/25016/Intel-Network-Adapter-Driver-for-Windows-10). That's where I get lost, don't why during iSCSI boot Windows is looking  for these two drivers that are not signed even if when corresponding latest drivers are available.

  Thanks for your help

-----Original Message-----
From: Johannes Thoma <johannes at johannesthoma.com> 
Sent: Wednesday, June 26, 2019 5:09 AM
To: Qing Zheng <qizheng at nvidia.com>; ipxe-devel at lists.ipxe.org
Subject: Re: [ipxe-devel] Desperately need help on booting Windows 10 from iSCSI

Am 23.06.19 um 01:01 schrieb Qing Zheng:
> Hi,

> [...]
> I have to go the advanced boot menu to disable driver signature check 
> then it can boot successfully. Once it is booted I checked the detail 
> of the network driver, it is actually using e1i63x64.sys not 
> e1i65x64.sys
If you are sure that you don't need the driver for booting, you can disable it by setting StartType to 3 and BootFlags to 0 in the registry (HKLM/Software/Services/ControlSet001/<driver>/*
BootFlags 1 means it is boot critical when booting via network and therefore gets only loaded when booting via iSCSI.

If you need the driver then you need to download and install a properly signed version of this driver (maybe the certificate just expired).

Please let me know if that helps.

- Johannes
This email message is for the sole use of the intended recipient(s) and may contain
confidential information.  Any unauthorized review, use, disclosure or distribution
is prohibited.  If you are not the intended recipient, please contact the sender by
reply email and destroy all copies of the original message.

More information about the ipxe-devel mailing list