[ipxe-devel] Issues compiling latest ipxe on FreeBSD 11

Christian Nilsson nikize at gmail.com
Sat Jan 7 00:11:00 UTC 2017

Trying to save some memory on load time by compressing if I'm not mistaken.
Is this with your patch applied? if so it is likely that your patch is
causing the issue, since it is just printfs maybe you should just
comment out those and see if that solves this issue?

On Fri, Jan 6, 2017 at 11:58 PM, Pete French <pete at twisted.org.uk> wrote:
>> Could you try different versions of iPXE on the same machine?, could
>> you try downgrading again?
> I can try multiple different machines - got access to a great many
> running various versions of BSD. I just tried a fresh 'git clone'
> on a completely freshly installed FreeBSD 11 machine - same error
> I am afraid.
>> Not a BSD user myself, but you might want to suspect some kind of
>> library or memory corruption?
> I;ve tried it on three different machines now with the same results, so its
> unlikely. What exactly is that part of the build process trying to do ?
> It looks like it is trying to compress the resulting binay possibly ?
> cheers,
> -pete.

More information about the ipxe-devel mailing list