[ipxe-devel] dhcp user-class check for "iPXE"

Christian Nilsson nikize at gmail.com
Thu Apr 20 17:18:49 UTC 2017

So you are sure it's the if statement that is never is hit, and not
that filename is set again after that filename inside the if?
Just as a test, remove all other filename definitions and check what you get.

Also double check with tcpdump that everything is as you expected.
Could you post your full dhcpd.conf so we can check it?

On Thu, Apr 20, 2017 at 3:18 PM, Linto Paul <lintopaul at gmail.com> wrote:
> Hi Christian,
> Yes I have tried different filename options later in my dhcp.conf for
> fallback such as ipxe.efi or undionly.kpxe but the issue is that the former
> condition for user-class "iPXE" is never met and always go the fallback
> filename specified.
> I've tried the Robin's example s already and also followed the ipxe forum
> but couldn't get it working yet.
> Best regards,
> Linto
> On 20-Apr-2017 6:08 PM, "Christian Nilsson" <nikize at gmail.com> wrote:
> Hi!
> Do you happen to have any filename set later in your dhcpd.conf ?
> I tend to refer to Robins extensive example at
> https://gist.github.com/robinsmidsrod/4008017 see ipxe-green.conf for
> ideas
> Other then that I would start checking with tcpdump for exactly what
> is sent both ways.
> You can find several threads at
> http://forum.ipxe.org/forumdisplay.php?fid=2 about RHEL and UEFI.
> (If you want to post in the forum, remember that it is moderated for
> new users, so won't be visible until a moderator have approved the
> post)
> /Christian
> On Thu, Apr 20, 2017 at 2:27 PM, Linto Paul <lintopaul at gmail.com> wrote:
>> Hello Folks,
>> I am trying to iPXE boot latest RHEL 7.3 on HP Proliant Gen 9
>> server(XL190R)
>> in UEFI mode but can't get the infinite dhcp loop to be broken using the
>> chain load option below:
>> if exists user-class and option user-class = "iPXE"{
>>     filename "xx.xx.xx.xx/default.ipxe
>> }
>> No matter what I try this condition is never met so always the control
>> goes
>> to the else condition and tries to boot off the bootloader provided there.
>> By the way, I am aware of using the ipxe compile option with embedded
>> script
>> to break from the loop but wasn't able to get it to boot as I get a kernel
>> panic.
>> Any help on getting around this dhcp option would be much appreciated.
>> Also,
>> any pointers on successful use cases with RHEL in UEFI mode would be
>> helpful
>> as well. From my understanding only RHEL 7.3 onwards can be used with iPXE
>> in UEFI mode but correct me if I am wrong.
>> Best regards,
>> Linto
>> _______________________________________________
>> ipxe-devel mailing list
>> ipxe-devel at lists.ipxe.org
>> https://lists.ipxe.org/mailman/listinfo.cgi/ipxe-devel

More information about the ipxe-devel mailing list