[ipxe-devel] WinPE behaves differently when started by wimboot

Andres, Roman Roman.Andres at netree.ch
Tue Mar 29 13:40:41 UTC 2016

Hi Christian,

What I missed to mention:
- The Surface Pro 3 and 4 devices are UEFI only, no legacy BIOS mode, no CSM. The boot image is always UEFI booted.
- The screen resolution issue is true for both Surface Pro devices 3 and 4, but always happens when PXE booting , doesn't matter if iPXE/wimboot or WDS.

My focus for now lies on the network adapter issue and I tested a few things.

I'm not sure if it could be a timing issue since I can reproduce the network adapter issue every time when PXE booting using iPXE/wimboot and I'm unable to reproduce it when booting the same image via:
- Local volume boot (WinPE is stored on a local volume and added to the local BCD)
- USB stick boot (created with Windows ADK tools MakeWinPEMedia /UFD, but based on the same WinPE image)
- WDS PXE boot

wpeinit is executed as the first command after WinPE was booted. I also tried wpeutil InitializeNetwork afterwards, but the only thing that helps after booting with iPXE/wimboot is unplugging the adapter and plugging it back in.

I tried the following things:
- Edited the BCD, which is downloaded by iPXE to have the same options set as the test clients local BCD which is used to boot the local WinPE image -> no change, same behavior.
- Replaced the bootmgrfw.efi and the bootmgr.efi in the WinPE image with the ones from the local system partition of the test client -> no change, same behavior.
- Replaced the boot.sdi with the one from the local system partition of the test client -> no change, same behavior.

I've added the gui parameter to wimboot as well as the fonts as well. I'm out of ideas for now.


More information about the ipxe-devel mailing list