[ipxe-devel] wimboot: regression between 2.1.0 and 2.2.0

Christian Nilsson nikize at gmail.com
Sun Feb 8 18:16:44 UTC 2015

git bisect as Shao mentioned, is the best wayt to find out what actually
caused this change.

Everything seems right and things should be working, the only thing that
could be changed is remove the initrd bootmgr.exe line (since it is
extracted from boot.wim by wimboot)

When you start testing efi remember to add -n filename in the begining of
the line to set the uefi filename. as well (is needed on your boot.wim line)

/ Christian Nilsson

On Sun, Feb 8, 2015 at 5:05 PM, Alexandre Blanchette <blanalex at gmail.com>

> I'm planning to jump into the UEFI bandwagon soon and I'm updating my
> wimboot setup from 1.0.3 to the latest version (currently 2.4.1). I tried
> to simply drop the new wimboot binary in place of the old one but all I got
> was a black screen. Adding the 'gui' parameter revealed a BSOD
> (SYSTEM_THREAD_EXCEPTION_NOT_HANDLED). I downgraded versions until it
> worked again and that was at version 2.1.0. So between 2.1.0 and 2.2.0
> something broke.
> My setup is currently pxelinux.0 (for the menu system) => ipxe (http
> requests with variables) => wimboot => WinPE 5.0 (SCCM). Test platform is
> VMWare Workstation 10.0.5
> The boot script:
> #!ipxe
> set wimboot-path http://some-server/wimboot
> kernel ${wimboot-path}/wimboot
> initrd ${wimboot-path}/bootmgr50.exe      bootmgr.exe
> initrd ${wimboot-path}/bcd                BCD
> initrd ${wimboot-path}/boot.sdi           boot.sdi
> initrd ${wimboot-path}/wgl4_boot.ttf      wgl4_boot.ttf
> initrd ${wimboot-path}/segmono_boot.ttf   segmono_boot.ttf
> initrd ${wimboot-path}/segoe_slboot.ttf   segoe_slboot.ttf
> initrd ${wimboot-path}/SCCM-EP3-WinPE50-x64.wim    boot.wim
> boot
> --
> Alexandre Blanchette <blanalex at gmail.com>
> _______________________________________________
> ipxe-devel mailing list
> ipxe-devel at lists.ipxe.org
> https://lists.ipxe.org/mailman/listinfo.cgi/ipxe-devel
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ipxe.org/pipermail/ipxe-devel/attachments/20150208/a24db106/attachment.htm>

More information about the ipxe-devel mailing list