[ipxe-devel] wimboot: regression between 2.1.0 and 2.2.0

Alexandre Blanchette blanalex at gmail.com
Sun Feb 8 16:05:19 UTC 2015

I'm planning to jump into the UEFI bandwagon soon and I'm updating my
wimboot setup from 1.0.3 to the latest version (currently 2.4.1). I tried
to simply drop the new wimboot binary in place of the old one but all I got
was a black screen. Adding the 'gui' parameter revealed a BSOD
(SYSTEM_THREAD_EXCEPTION_NOT_HANDLED). I downgraded versions until it
worked again and that was at version 2.1.0. So between 2.1.0 and 2.2.0
something broke.

My setup is currently pxelinux.0 (for the menu system) => ipxe (http
requests with variables) => wimboot => WinPE 5.0 (SCCM). Test platform is
VMWare Workstation 10.0.5

The boot script:
set wimboot-path http://some-server/wimboot
kernel ${wimboot-path}/wimboot
initrd ${wimboot-path}/bootmgr50.exe      bootmgr.exe
initrd ${wimboot-path}/bcd                BCD
initrd ${wimboot-path}/boot.sdi           boot.sdi
initrd ${wimboot-path}/wgl4_boot.ttf      wgl4_boot.ttf
initrd ${wimboot-path}/segmono_boot.ttf   segmono_boot.ttf
initrd ${wimboot-path}/segoe_slboot.ttf   segoe_slboot.ttf
initrd ${wimboot-path}/SCCM-EP3-WinPE50-x64.wim    boot.wim

Alexandre Blanchette <blanalex at gmail.com>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ipxe.org/pipermail/ipxe-devel/attachments/20150208/c456f7e5/attachment.htm>

More information about the ipxe-devel mailing list