[ipxe-devel] netinstall nbi image of ipxe

David Krovich david.krovich at mail.wvu.edu
Sat Feb 7 08:59:19 UTC 2015

Hi list,

I'm trying to use a mac laptop as a client to boot ipxe via a mac 
netinstall server nbi image.

My setup is Yosemite Server on the Mac server.

I'm using dnsmasq to provide tftp and dhcp options for pxe filename and 

I grabbed the netinstall nbi from here:


On my mac laptop client, it boots and I "n", it boots off the netinstall 
image and the ipxe screen comes up fine.  The problem is when it tries 
to download the pxelinux.0 file via tftp I get a permission denied error 
message.  It points me to http://ipxe.org/0212608f.

I've tested my pxe installation by using virtualbox running on a 
different machine and it gets on the network and downloads the pxelinux 
file without issue.

For another test I disabled dnsmasq, and setup isc dhcp and tftp server 
on another machine.  I get the same result, but a slightly different 
error message.  http://ipxe.org/2d03e18e

Again I tested this second setup with virtualbox and it worked fine as well.

Any ideas on the next thing I can attempt to do to debug this issue?


More information about the ipxe-devel mailing list