[ipxe-devel] Windows bootup problems after successfull wimboot-iscsi setup

Andrew Bobulsky rulerof at gmail.com
Mon Nov 17 15:03:51 UTC 2014


The 7E stop code is usually something esoteric.  If the drivers weren't
loading up at all, you'd get a 7B error, or "Inaccessible Boot Device."

As I recall, anyway ;)

I saw that you scripts set your gateway to Something makes me
think that this may be causing a problem. I believe Michael added
functionality to his sanbootconf driver that works around the gateway issue
in a very clean way; you may want to try bundling it into your WinPE.

Anyway, I speculate that your gateway of might be a problem...
Because that's *technically* a real IP address.

Try clearing the setting completely instead, by running

clear netX/gateway

in place of the line where you're setting it.

No clue if it'll help, but I'd say it's wort a shot :)


On Monday, November 10, 2014, Ivan Krutskikh <stein.hak at gmail.com> wrote:

> Hi,
> Thou this is not technically speaking a ipxe question, but I think this is
> an appropriate place to get some help with it.
> So I am developing a Linux/Windows diskless boot system based on ipxe,
> zfsonlinux and python. Linux part works like a bliss with multiple distros,
> different hardware e.t.c.
> At first I made some progress with windows 7 too, using pure cd-rom setup
> for single station ( a supposed to be  a Microsoft supported scenario) and
> a ccboot client v2.0 for injecting multiple nic drivers for different
> hardware.
> I used the same booting script for both:
> eg:
> #!ipxe
> set keep-san 1
> set netX/gateway
> sanboot iscsi:
> But after some time ( maybe some windows updates as well, hard to tell)
> the whole windows booting sequence broke and I cannot fix it or reproduce
> it with fresh install. All windows bootups end with hang windows logo
> followed by
> bsod 7e and a reboot. As far as I can tell, this is because windows
> couldn't find the driver for main hdd storage. ( basically, it is the lan
> driver + msicsi)
> After some experiments with never ccboot versions, I tried a different
> approach based on http://ipxe.org/howto/winpe. So I made a custom 3.0
> winpe, booted it with ipxe script:
> #!ipxe
> set netX/gateway
> sanhook  iscsi:
> kernel
> initrd BCD
> initrd boot.sdi
> initrd boot.wim
> boot
> My nic was perfectly recognized and configured, windows 7 setup was able
> to see my iscsi drive and installed windows just like it would on a local
> hdd. But after reboot- same old story. Bootup hangs, BSoD 7e. Tried
> launching a local VM from the same media, which was used to provide iscsi
> target- setup finished succesfull, new desktop welcomed me.
> At this point I'm out of ideas. What differs installing windows by winpe
> to iscsi from the same scenario with cdrom? Not to mention there are a
> number of tutorials on the internet suggesting the second method for client
> provision.
> What am I doing wrong here?
> Thanks in advance.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ipxe.org/pipermail/ipxe-devel/attachments/20141117/650d4d02/attachment.htm>

More information about the ipxe-devel mailing list