[ipxe-devel] is wimboot compatable with WinPE 5.1 ?

Robin Smidsrød robin at smidsrod.no
Wed Jun 25 08:51:48 UTC 2014

On 23.06.2014 22:06, Bain.John wrote:
> For the  last while I have been using pxelinux to launch wimboot 1.0.4
> to boot my windows deployment built with WinPe 4.0
> Recently however I have upgraded my deployment and am now using WinPE
> 5.1 . Using my old configuration, I’ve upgraded wimboot to 1.0.6 , I
> have copied over my new boot files and I am still not able to boot into
> WinPE 5.1
> This is what my configuration looks like.
> /label engref2/
> /menu label Engref2/
> /com32 linux.c32/
> /append wimboot /
> /initrdfile=,,,,,,,
> This configuration use to work in WinPE 4 but no longer in WinPE 5.1

Have you tried using a plain iPXE script to load WinPE 5.1 (that's based
on Windows 8.1, right)? Syslinux didn't have the initrd auto-wrapping
feature earlier, but if you're saying that the above config was working
earlier I'm assuming you have Shao's patch installed and working.

If an iPXE script is working in loading it properly, then you'll need to
get into debugging how the initrd files are loaded, which I assume is
probably your culprit.

-- Robin

More information about the ipxe-devel mailing list