[ipxe-devel] Weird issue booting to x64 WinPE 3.0 or 4.0 after mounting iSCSI disc

Steve Cross hairlesshobo at stevecross.org
Mon Jul 1 18:33:18 UTC 2013

OK so I am having a very strange issue, and it's only occurring on one
system of mine.

Background on environment:

2 separate WinPE installations, both 3.0. One is for 32 bit only and one is
for 64 bit only.
2 separate Windows 7 install CDs on a network share, one for 32 bit only
and one for 64 bit only.
In my iPXE list, I have a category for installers, and that list there are
the following options:

   - Install Windows 7 x86 to Local HDD
   - Install Windows 7 x64 to Local HDD
   - Install Windows 7 x86 to iSCSI
   - Install Windows 7 x86 to iSCSI

The ONLY difference between the top two options and the bottom two, is that
the bottom two sanhooks the iSCSI drive prior to wimbooting. I have used
this exact setup on countless machines with no problem... except this one
particular one.

If I try to use the Install Win7x64 to iSCSI, then the WinPE Freezes almost
immediately and will not boot. If I use the Win7x86 option, it boots right
up no problem.
If I use either of the installers to local hdd (64 bit included) then it
boots right up, just no HDD present to install to.

Does anyone have ANY clue what could be going on. I really don't think the
64 bit WinPE is the problem since it will boot up no problem if i skip the
sanhook command, and it works perfect on all the other machines I've ever
used it on.

I even tried adding the factory drivers to that WinPE (just in case, even
though it is a driver the Win 7 has by default) but there was no difference.

I pulled back the latest snapshot of iPXE and did a fresh compile to see if
maybe that would help, but it has not. I am currently using the
undionly.kpxe file which works great on the other 3 iSCSI clients that I
have. The NIC is a Yukon Marvell 1GB card (I made sure not to use the
nVidia card that is also on this board cause I know the iSCSI + nVidia card
= no go). At this point, I am at a loss for ideas.

Just for kicks, I even tried using WinPE 4.0 to see if it would work, and
it would boot, but only if i didn't first sanhook the iSCSI drive. I know
the iSCSI drive isn't the problem either because i can install Windows 7
x86 to iSCSI and it boots up fine and shows the disk just as expected.

Any got any ideas or pointers of where I could look next? I really don't
want to have to use a physical HDD.

I WOULD be willing to do a clean install to physical HDD and then transfer
it to iSCSI, but every time I've tried in the past it's failed with the
infamous inaccessible boot device error, so if that is my only option,
maybe someone can give me some pointers on how to migrate an existing
system from physical HDD to iSCSI.

Thank you very much in advance!!!

*Steve Cross*
hairlesshobo at stevecross.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ipxe.org/pipermail/ipxe-devel/attachments/20130701/6afe45df/attachment.htm>

More information about the ipxe-devel mailing list