[ipxe-devel] Sanboot hangs on HP BL460c G7

Andrew Bobulsky rulerof at gmail.com
Tue Jan 8 15:35:42 GMT 2013


On Jan 8, 2013, at 10:10 AM, Gavin Williams <gavin.williams at weareact.com>
wrote:

Just tried ‘sanboot’ from an ipxe shell, and got the following:

‘Could not describe SAN device 0x80: No such device (
http://ipxe.org/2c85203b)’



Had a look at the page referenced, but didn’t make much sense to me…

I’m fairly sure I’m running the latest version…



Any ideas?



Cheers

Gavin



*From:* Gavin Williams
*Sent:* 08 January 2013 14:43
*To:* Andrew Bobulsky
*Cc:* ipxe-devel at lists.ipxe.org
*Subject:* RE: [ipxe-devel] Sanboot hangs on HP BL460c G7



Andrew



Havent tried sanhook or sanunhook… Can do though…



And no, I don’t get any ‘registered… ‘ output…



Just get:

‘Booting from SAN Device 0x80’.

Have attached a screenshot of the console…



This is using the following ipxe script:

#!ipxe

echo Razor <%= @label %> model boot_call

echo Installation node UUID : <%= node.uuid %>

echo Installation image UUID: <%= @image_uuid %>

echo Active Model node state: <%= @current_state %>

echo Continuing local boot



sleep 3

sanboot --no-describe --drive 0x80



Any ideas???


Cheers

Gavin

<snip>

Oh okay, you're using sanboot against a local drive.  That does usually
work, but ironically enough, you're the second fellow in as many days to
have the exact same problem with a Proliant server here on the list ;)

There was a similar issue regarding virtualbox as well on the list in the
past few days, and I typed up a workaround to the problem as an application
note on the wiki yesterday, and would love to be able to either verify that
it works on other systems, or at least confirm that I should come up with
some more options!  Care to give it a try? :)

http://ipxe.org/appnote/work_around_bios_halting_on_ipxe_exit

Cheers,
Andrew Bobulsky
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ipxe.org/pipermail/ipxe-devel/attachments/20130108/226bff44/attachment-0001.html>


More information about the ipxe-devel mailing list