[ipxe-devel] Flashing Intel NICs with BootUtil.exe

Robin Smidsrød robin at smidsrod.no
Tue Oct 30 16:16:34 GMT 2012


Hi Brandon,

I would love it if you could put in a response to that forum post about
the different behavior of these two different versions of
bootutil/ibautil. Hopefully it'll help other people looking for a
solution while we figure out what is the actual problem with the newer
version.

-- Robin

On 30.10.2012 16:02, Brandon Penglase wrote:
> All,
> 	I was wondering if anyone has found the same thing that I did,
> while trying to flash Intel NICs with iPXE. If you go and download the
> latest preboot.exe (I got mine from here:
> http://downloadcenter.intel.com/Detail_Desc.aspx?ProductID=412&DwnldID=19186&lang=eng&iid=dc_rss
> version 17.4, which gives a bootutil.exe version of 1.4.03.0, it
> apparently does not like the rom format that iPXE presents. When I try
> to use it, I get the following (I renamed the rom file for later):
> 
>> bootutil -nic=1 -up=pxe -file=80861229.iba
> 
> Intel(R) Ethernet Flash Firmware Utility
> BootUtil version 1.4.03.0
> Copyright (C) 2003-2012 Intel Corporation
> 
> ERROR: Input file invalid format
> 
> Port Network address Series  WOL Flash Firmware     Version
> ==== =============== ====== ==== ================== =======
>  1   0002B365A2E0    10/100 YES  Flash Unknown
> 
> (Note, echo %errorlevel% shows error 14).
> Also, I tried the bootutil in Linux, and got the same error. I also
> tried many forms of the filename, and it didn't change the error.
> 
> However, grabbing the old prorpl.exe, from
> http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=11271&keyword=prorpl.exe&DownloadType=Utilities%2c+Tools+and+Examples&OSFullname=OS+Independent&lang=eng
> version 10.4, IBAUtil version 3.03.06.00, it works fine, with the
> following:
> 
>> ibautil.exe -nic=1 -restore
> Intel(R) Boot Agent Utility
> IBAUtil Version 3.03.06.00
> Copyright (C) 2002-2004 Intel Corporation
> 
> Restoring image on NIC1 from file 80861229.IBA...done
> 
> NIC Network Address Series  WOL Boot ROM Type    Version
> === =============== ======  === ================ ========
>  1  0002B365A2E0    10/100  YES PXE/RPL	         88.106.129
> 
> Indeed, upon reboot, I'm presented with iPXE.
> 
> In my searching, I found an old forum posting, with suggestions from
> Robin, however no reply after that:
> http://forum.ipxe.org/showthread.php?tid=3420
> Trying the suggestion (also suggested by Shao on IRC), I reduced the
> size of the image, and padded it to the size of one saved from the
> bootutil, and I still got the same error message. 
> 
> At this point, it seems either the ROM needs to be saved in a new
> format for the bootutil, or we have to use the old ibautil to flash it.
> 
> Has anyone found this, or found a way to get it to work with the new
> bootutil? 
> 
> 	Brandon Penglase
> _______________________________________________
> ipxe-devel mailing list
> ipxe-devel at lists.ipxe.org
> https://lists.ipxe.org/mailman/listinfo.cgi/ipxe-devel
> 



More information about the ipxe-devel mailing list