[ipxe-devel] Recent tg3 driver commits still fail on gigabit

Calvin Owens jcowens at smu.edu
Fri Oct 19 03:23:11 UTC 2012

On 10/18/12 21:41, Brandon Penglase wrote:
> FYI to all, apparently Apple's Thunderbolt to Ethernet adapter
> (http://store.apple.com/us/product/MD463ZM/A/thunderbolt-to-gigabit-ethernet-adapter)
> uses the 57762 chip (PCI ID 14e4:1682). Looks like these
> patches also fixes an issue with that card. A person by the name of
> BoRiS came into the IRC channel reporting that this adapter with a
> Retina Macbook Pro, was not working (even on 100mbit). Once these
> patches were applied, it started working. 
> Maybe this also is the fix for the other thread about the iMacs?
> 	Brandon Penglase

I'll try Kevin's patches in our iMac lab tomorrow afternoon and let you
know the result.


> On Tue, 16 Oct 2012 17:20:16 +0000
> "Kevin Tran" <ktran at broadcom.com> wrote:
>> Attached are the patches that will fix issues where iPXE fails in
>> 1Gbps mode when APE (management firmware) is disabled.  Brandon and
>> others have confirmed that these patches fixed their problems.  
>> -----Original Message-----
>> From: Kevin Tran 
>> Sent: Monday, October 08, 2012 3:28 PM
>> To: 'Brandon Penglase'; ipxe-devel at lists.ipxe.org
>> Subject: RE: [ipxe-devel] Recent tg3 driver commits still fail on
>> gigabit
>> Hi Brandon,
>> We were able to reproduce the issue you reported on BCM5764m.  We
>> already resolved this.   I will send you the fixes on other e-mail.
>> Once you confirm that your issue is fixed, we will submit the changes.
>> Thanks!
>> Kevin
>> -----Original Message-----
>> From: Brandon Penglase [mailto:bpenglase-ipxe at spaceservices.net]
>> Sent: Wednesday, August 22, 2012 10:57 AM
>> To: ipxe-devel at lists.ipxe.org
>> Cc: Kevin Tran
>> Subject: Re: [ipxe-devel] Recent tg3 driver commits still fail on
>> gigabit
>> Kevin,
>> 	Thanks for getting back to us.
>> 	It seems the only b57diag I've been able to find is from 2004
>> (or earlier). The download I'm finding on the website is for
>> b57udiag, which doesn't seem to have the -b57eng option. When I use
>> the one from 2004, I get "Invalid device 0 requested." I don't
>> believe there is any sort of management on this machine that would be
>> involved. It's a Dell FX160, BIOS A07. It does have the ImageServer
>> option, but it is not currently enabled. According to the b57udiag
>> -dir it finds: 0 5764M:B0 02:00:0 Ex1 250 FEBF 10 128k/128k
>> 00262d21e4ec 5764m-v3.35 W
>> 	If it helps, I only have the problem when booting with a
>> ipxe.usb thats been DD'd to a 2gb thumb drive. I haven't tried a CD
>> yet, but using the built in UNDI to chainload to iPXE ends up working
>> fine. I have used two different gigabit switches, the original was a
>> 16port Linksys one, the current is a 8port Netgear GS108.
>> 	Brandon Penglase

More information about the ipxe-devel mailing list