[ipxe-devel] Query on UEFI iPXE boot

Sanjeev.Roy at Emulex.Com Sanjeev.Roy at Emulex.Com
Wed Dec 21 19:02:23 UTC 2011

Hi All,
We tried UEFI IPXE boot with  an Intel igb CNA. The device ID was 10c9. We built 808610c9.efi. However while trying the UEFI iPXE boot using the .efi file we could see that the client is able to successfully download the 808610c9.efi file. The client hangs after that. It never tries to get the bootx64.efi (required for booting to the EFI mode) file after that.

We were trying the UEFI boot with  Sles11sp164.
Has anyone executed chain loading using iPXE in UEFI environment?


-----Original Message-----
From: Michael Brown [mailto:mbrown at fensystems.co.uk] 
Sent: Saturday, December 17, 2011 1:02 AM
To: ipxe-devel at lists.ipxe.org
Cc: Roy, Sanjeev
Subject: Re: [ipxe-devel] Query on UEFI iPXE boot

On Wednesday 14 Dec 2011 12:32:10 Sanjeev.Roy at emulex.com wrote:
> We are using Emulex adapter.
> We tried chainloading for EFI using iPXE similar to legacy boot, legacy
> boot works fine.
> The configuration change in dhcpd.conf is
> if exists user-class and option user-class = "iPXE" {
>        filename "bootx64.efi"; # bootx64.efi is located @ tftp root
> } else {
>        filename "808610de.efi"; #808610de.efi is located @ tftp root
> }
> also tried with e1000e--r8169.efi and ipxe.efi instead of 808610de.efi

8086:10de is an Intel e1000 card.  You need to use the PCI IDs for your Emulex 
card instead.

> Is there any specific way to generate the binary for Emulex adapter, which
> is not been specified in e1000e_ich8lan.c, In this case how do we build
> the driver image specific for this adapter.

Emulex adapters are not (as far as I am aware) direct equivalents of Intel 
e1000 adapters.  You need to create an iPXE driver for Emulex adapters (or pay 
to have one created).


More information about the ipxe-devel mailing list