[ipxe-devel] Query on UEFI iPXE boot

Michael Brown mbrown at fensystems.co.uk
Fri Dec 16 19:31:40 UTC 2011

On Wednesday 14 Dec 2011 12:32:10 Sanjeev.Roy at emulex.com wrote:
> We are using Emulex adapter.
> We tried chainloading for EFI using iPXE similar to legacy boot, legacy
> boot works fine.
> The configuration change in dhcpd.conf is
> if exists user-class and option user-class = "iPXE" {
>        filename "bootx64.efi"; # bootx64.efi is located @ tftp root
> } else {
>        filename "808610de.efi"; #808610de.efi is located @ tftp root
> }
> also tried with e1000e--r8169.efi and ipxe.efi instead of 808610de.efi

8086:10de is an Intel e1000 card.  You need to use the PCI IDs for your Emulex 
card instead.

> Is there any specific way to generate the binary for Emulex adapter, which
> is not been specified in e1000e_ich8lan.c, In this case how do we build
> the driver image specific for this adapter.

Emulex adapters are not (as far as I am aware) direct equivalents of Intel 
e1000 adapters.  You need to create an iPXE driver for Emulex adapters (or pay 
to have one created).


More information about the ipxe-devel mailing list