[ipxe-devel] ISO SAN booting

Andrew Stuart andrew at shopcusa.com
Thu Apr 28 05:23:07 UTC 2011

On 4/27/2011 3:30 PM, Michael Brown wrote:
> It is now possible to use iPXE to directly boot from an ISO image held on a
> SAN target (e.g. AoE, iSCSI, FCoE).  This has the same limitations as using
> memdisk to boot an ISO image, but without the memory overhead or initial
> download delay of memdisk.
> There's no special syntax: just make the ISO image available on the SAN target
> and then attempt to boot from it (using "sanboot" or with a DHCP root-path).
> For example:
>    (on server)  vblade 0 0 eth0 /path/to/winpe.iso
>    (on iPXE)  sanboot aoe:e0.0
> I have tested that WinPE and the VMware installer are able to start using this
> method.  I'd appreciate any further testing.
> Michael
> _______________________________________________
> ipxe-devel mailing list
> ipxe-devel at lists.ipxe.org
> https://lists.ipxe.org/mailman/listinfo/ipxe-devel

---oops replied to Michael and not list.. ---

Hrm no joy here. If I am to understand correctly, this doesn't need 
anything special done to the iso image, and any image memdisk iso is 
able to boot, this should as well?

Using vblade 20 on FreeBSD 8.2:
andrew at scrappy:# vblade 1 1 em0 ACTIVE-BOOT-DISK.ISO
ioctl returned -1
124221440 bytes
pid 62690: e1.1, 242620 sectors O_RDWR

I did a git pull after this email, gmake clean / gmake
boot the iso / CTRL-B to break to a prompt:
ifopen net0
sanboot aoe:e1.1

(note, I tried e1.1 after e0.0 didn't work because I didn't remember to
ifopen net0)

Loading a winpe 1.0 image fails with:
SETUPLDR: Couldn't open drive multi(0)disk(0)rdisk(0)partition(1)

Loading a winpe 3.0 image fails with:
Windows Boot Manager
Windows failed to start. ...
File: \Boot\BCD
Status: 0xc000000e
Info: An error occurred while attempting to read the boot configuration 

I tried multiple images, including the image from here: 

and lastly chose to try a known working with memdisk iso file, mfsbsd: 

All attempts were on Vmware Workstation 7.1.4, configured initially with 
512mb of ram, and then again tested with 1gb.


actually while trying to figure out what git revision I was on, I pulled 
in another change to one of the files, and that seems to have fixed the 
mfsbsd iso mentioned above.. Windows isos still don't seem to be happy 

What else can I provide to help figure this out?


More information about the ipxe-devel mailing list