[ipxe-devel] [ipxe/pipxe] Raspberry Pi 4? (#2)

IntelMiner notifications at github.com
Thu Mar 25 15:32:05 UTC 2021

Apologies for the necro-post. But this was one of the first results in Google 

I've been tearing my hair out for several hours now trying to get a scripted iPXE to boot on my Raspberry Pi 4. I've tried using both the iPXE upstream, as well as the version 1.20.1 build that @rgl's repository provides 

No matter what version I build, executing a `make bin-arm64-efi/ipxe.efi EMBED=myscript.ipxe` or even building without the script builds a binary that boots, but then does not show any ethernet devices :(

I've got the latest EFI 1.24 firmware running, and have also tried 1.16 and 1.17 due to at least one thread noting that it may have errors netbooting 

I've found a few pre-made iPXE binaries that do already work, but I want to embed a script in to mine for HTTP booting

Is `make bin-arm64-efi/ipxe.efi` still the correct build command for the Raspberry Pi 4? Or am I missing some step somewhere

You are receiving this because you commented.
Reply to this email directly or view it on GitHub:
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ipxe.org/pipermail/ipxe-devel/attachments/20210325/1881f3fc/attachment.htm>

More information about the ipxe-devel mailing list