[ipxe-devel] [ipxe/pipxe] Raspberry Pi 4? (#2)

IntelMiner notifications at github.com
Sun Apr 4 09:42:16 UTC 2021

@PeterSurda Update!

It took some finesseing to get it to work on my build box (Gentoo needed the `iasl` package for those relevant files)

I ran into an ipxe build error with some junk relating to "infiniband" (possibly an issue with using GCC 10.2?) but commenting that out fixed it

Embedding my boot script seemed to work as well. It pulls down a kernel + initrd and (attempts) to boot them

However it now hangs at

`EFI stub: Booting Linux Kernel...`
`EFI stub: Generating empty DTB`
`EFI stub: generating boot services and installing virtual address map...`

But I know that's (probably) outside the scope of iPXE and likely a kernel configuration issue on my side

Thank you very much for all your help however :) Hopefully this thread helps others in future too

You are receiving this because you commented.
Reply to this email directly or view it on GitHub:
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ipxe.org/pipermail/ipxe-devel/attachments/20210404/36ff9863/attachment.htm>

More information about the ipxe-devel mailing list