[ipxe-devel] chainload iPXE from grub.cfg

Steininger, Herbert herbert_steininger at psych.mpg.de
Thu Oct 22 12:52:42 UTC 2020


thanks for getting back.

I solved the problem, don't ask ☺
It was some kind of PICNIC
I commented the wrong line in the boot.ipxe

Everything is working now as expected.


Von: Christian Nilsson [mailto:nikize at gmail.com]
Gesendet: Donnerstag, 22. Oktober 2020 12:53
An: Steininger, Herbert <herbert_steininger at psych.mpg.de>
Cc: ipxe-devel at lists.ipxe.org
Betreff: Re: [ipxe-devel] chainload iPXE from grub.cfg

On Thu, 22 Oct 2020 at 11:49, Steininger, Herbert <herbert_steininger at psych.mpg.de<mailto:herbert_steininger at psych.mpg.de>> wrote:

I have dnsmasq (built-in tftp enabled) and apache.

Legacy PXE Boot is working fine.

I also want to boot Win10 Install Images through UEFI.

This works when I use ipxe as a boot-file in dnsmasq, as expected.
I'm able to chainload wimboot/win10 from CLI or load from an embedded script in ipxe, both works.

But I would like to boot grub (BOOTX64.EFI) and chainload ipxe from it.
Well, this also work, at the beginning.

After UEFI-PXE boots my grub.cfg shows up.
I select "Windows 10 Install" which looks like this in grub.cfg:

menuentry "Windows 10 Install" --id win10 {
    insmod chain
    chainloader (tftp)/ipxe.efi

this loads the ipxe.efi from the tftp, and the embedded ipxe-script loads a boot.ipxe from apache, this also works,
I see it in the logs and ipxe says "ok".

But after that the Win10 install does not start, it will just fall back to the grub.cfg and no keypresses are recognized anymore.

Do someone have a clue what is going on or what I can do to debug?
Is there something missing?


So to be clear, the EFI boot path works fine when ipxe is loaded directly and not via grub?
But when you chain ipxe from grub then wimboot and the windows env fails?

How does your iPXE script look like?
Have you tried adding appropriate debug flags to wimboot, and also have you done a imgstat before your wimboot "boot" line to make sure there is no unexpected files loaded?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ipxe.org/pipermail/ipxe-devel/attachments/20201022/f5871de2/attachment.htm>

More information about the ipxe-devel mailing list