[ipxe-devel] "Installation failed" on 3Com 905B cards

Quinn Plattel qiet72 at gmail.com
Wed Mar 13 09:15:08 UTC 2019


I have done a lot of experimentation with getting ipxe up and running on
old network cards such as the 3Com 905B, Realtek 8139, and the D-Link
DFE-530TX cards.  I bought a bunch of Atmel 29C512 DIP32 eeprom's for
testing.  Much to my delight, I found out I was able to program these
eeprom's through the 3Com 905B DIP32 socket using the open source flashrom

I did some testing back and forth to make sure I could program the eeprom's
and read them back to verify the code was programmed correctly.

Previously, I did a lot of ipxe testing using USB keys, floppies, and
chainloading it via pxelinux and syslinux - all working fine.

Then I started to see if I could get the code to run on these eeproms.  I
first tested on a 3Com 905B.  The code seems to be recognized by the bios
but as soon as I press CTRL-B or let it try and boot the code, I then get
an error that says this:

iPXE (PCI 04:04.0) starting execution...1B101B10 00107A74 00000722
Installation failed - cannot continue

I tried the same thing on the D-Link DFE-530TX and it seems to run ok on
that card.  I have tried both rom and mrom formats but it gives the same
error on the 3Com card.

My compile command is (in src directory): make -j 8 bin/10b79055.rom
>From what I understand, this should compile a 32-bit binary.
The resulting rom size is 61440 bytes which is enough to fit in the Atmel
29C512 chip.

I disabled the following options in general.h to get the size under 64KB:

I also did the following to align the rom to 64KB:
perl -e 'print "\xFF" x 65536' >3com.rom
dd if=10b79055.rom of=3com.com conv=notrunc

This fills the rest of the unused space with 0xFF bytes.

Any ideas what the problem could be?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ipxe.org/pipermail/ipxe-devel/attachments/20190313/5a374227/attachment.htm>

More information about the ipxe-devel mailing list