[ipxe-devel] re. Memory usage with wimboot

Steve steve at easy2boot.com
Tue Jan 1 11:01:48 UTC 2019


Happy New Year!

I am the developer of Easy2Boot (www.easy2boot.com).

I am using wimboot to boot from a Windows ISO from a USB flash drive using

A sample grub4dos menu is:

title Install Windows10x64UK_Oct_2018 using wimboot method
map /Windows10x64UK_Oct_2018.iso (0xff)
map --hook
root (0xff)
# the root path now points to the files inside the ISO file
# hd0,0 is the USB drive that we booted from
kernel (hd0,0)/wimboot image=2
initrd @startup.bat=(hd0,0)/startup.bat @winpeshl.ini=(hd0,0)/winpeshl.ini
@bootmgr=/bootmgr @bcd=/boot/bcd @boot.sdi=/boot/boot.sdi

I am using current version of wimboot (size 51,392 bytes, 17 May 2017)
When I boot from a virtual system (Virtual Box) which has 1024MB of RAM, I
get various memory problems reported by WinPE.
If I run taskmgr.exe it reports Total Memory 683, Cached 107, Available 27,
Free 5.
If I run the same ISO using a standard grub4dos mechanism, taskmgr.exe
reports the system has 1023MB of memory and I get no memory issues (Total
1023, Cached 262, Available 394, Free 140).
If I increase the amount of RAM to 2GB there is no problem using wimboot.

Is this to be expected or has wimboot failed to release some memory?

Many thanks
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ipxe.org/pipermail/ipxe-devel/attachments/20190101/349694fa/attachment.htm>

More information about the ipxe-devel mailing list