[ipxe-devel] blank screen, then back to grub. What to do next?

Ian Kelling ian at iankelling.org
Fri Oct 7 08:53:33 UTC 2016

On Thu, Oct 6, 2016, at 10:06 PM, Christian Nilsson wrote:
> Hi,
> Always start with using the absolute latest ipxe git master, you can find a prbuilt image at http://boot.ipxe.org
> Check that the ipxe version works with other boot methods, that means using ipxe.usb on a usb stick or ipxe.pxe chained over the network.

I have 2 environments I can do things in: grub2 (on coreboot/libreboot), 
and linux.

I could also try to make ipxe into a libreboot payload, but that seems
like it would definitely be harder than getting grub2 working.

linux will only boot another os using kexec, which only linux
so it's out.

grub2 on coreboot's main limitation is it does not support network
boot or bios chainloading. So, no pxe chaining to ixpe.

I tried the latest http://boot.ipxe.org/ipxe.lkrn using grub2's linux16
command. Same result, black screen for a few seconds then back
to grub.

The other way libreboot's default grub config will boot for usb is
syslinux_config command, which according to the cli help "executes
syslinux config in same context", anyways, it does not work on the
ipxe.iso or ipxe.usb.

Perhaps there is some other grub2 config or command to use?

Note, I've found that grub2 has changed somewhat significantly since the
latest online manual was published, and some commands are only
documented in the cli and source code.

More information about the ipxe-devel mailing list