[ipxe-devel] sanboot over iSCSI - halts

Michael Brown mcb30 at ipxe.org
Tue Jan 19 08:02:03 UTC 2016

On 18/01/16 13:04, manoj hirway wrote:
>                  I tried booting an existing Ubuntu VM image (.raw) that
> I exposed as an iSCSI LUN, using iPXE sanboot. (Both the iSCSI target
> and Client are on the same LAN)
> It started the boot process, however, it seems Ubuntu could not mount
> the root file system and gave me a initramfs prompt.
> I also tried the same with Windows images and I got a BSoD (Blue Screen
> Crash).
> Can’t we use existing VM images that were created using VMware ESX or
> Virtualbox ? Why is the root file system not mounted, when booted from
> iPXE ?
> Am I missing something ?

The initramfs in your VM image needs to be prepared to mount its root 
filesystem from the iSCSI LUN.

The process for Ubuntu will include installing the iSCSI initiator package:

   apt-get install open-iscsi

and adding the line


to /etc/iscsi/iscsi.initramfs, and then rebuilding the initramfs:


and probably some other minor changes.  I haven't personally tested this 
with Ubuntu, so can't give you the exact steps.


More information about the ipxe-devel mailing list