[ipxe-devel] DHCP problems on Intel 82567LM

Christian Hesse list at eworm.de
Fri May 2 11:01:02 BST 2014


Michael Brown <mcb30 at ipxe.org> on Fri, 2014/04/25 16:36:
> On 25/04/14 08:31, Christian Hesse wrote:
> > This is how to reproduce:
> >
> > * Boot ipxe.lkrn from Grub (so no UNDI involved)
> > * iPXE gets IP address via DHCP and fetches its config
> > * Select to boot Linux (kernel version 3.14.1)
> > * Try to get IP address via DHCP from inside Linux system
> >
> > DHCP just times out (though mii-tool reports link is ok) and I have to
> > power off the system to make the network controller work again. No issues
> > booting the same system from Grub directly or via iPXE from BIOS/UNDI.
> 
> Does unplugging and replugging the cable have any affect?

No.

> Do all the various indicators of link speed (switch LEDs, ethtool, 
> mii-tool etc) agree on the negotiated link speed?

Tried with an USB adapter (Cisco switch first time) connected to my notebook
to test some different hardware. Exactly the same:

server# mii-tool usb
usb: negotiated 100baseTx-FD, link ok

client# mii-tool enp0s25
enp0s25: negotiated 100baseTx-FD, link ok

> Is the datapath broken in both directions?

No. The Dell notebook (the one acting as client and having the problem)
receives packets. I can not see a single ethernet frame on the network sent
from the notebook.

> Are you able to transmit ARP 
> requests or broadcast pings, or observe received data via tcpdump?

tcpdump receives all types of packets on the notebook.

Did a warm reboot and tried to boot via UNDI. BIOS reported:

> PXE-E05: The LAN adapter's configuration is corupted or has not been
> initialized. The Boot agent cannot continue.

Though this is not reproducible. After a cold reboot everything ist just fine
again.
-- 
main(a){char*c=/*    Schoene Gruesse                         */"B?IJj;MEH"
"CX:;",b;for(a/*    Chris           get my mail address:    */=0;b=c[a++];)
putchar(b-1/(/*               gcc -o sig sig.c && ./sig    */b/42*2-3)*42);}
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 490 bytes
Desc: not available
URL: <http://lists.ipxe.org/pipermail/ipxe-devel/attachments/20140502/5361e0a9/attachment.asc>


More information about the ipxe-devel mailing list