[ipxe-devel] [gPXE] gpxe on USB or HD

Yadin Flammer yxf4 at psu.edu
Wed Jun 19 00:23:10 UTC 2013

No changes to code, I'm no programer.

I have done:
sudo dd if='/path/to/file/ipxe.usb' of=/dev/sdc
When that failed I cd to the directory of the file and do:
sudo dd if=ipxe.usb of=/dev/sdc

Previously as mentioned I had been doing of=/dev/sdc1 but was told that 
was wrong.

In all cases, there are no errors, it displays bytes in and out and 
transfer rate acting like it did something, but in no case does it 
actually do anything as the usb flash drive is unaltered every time.

I obtained the device path with:
sudo fdisk -l

As mentioned I have also tried to dd the gpxe.usb file downloaded from 
the old site with the same results.

Ubuntu 12.0.4 LTS fully updated as of today.

   Yadin Flammer - Systems Administrator
   College of Arts & Architecture, Penn State University
   228 Borland Building              Office Phone: 814-865-0990
   University Park, PA 16802         Dept. Phone:  814-865-1571
   Email: yxf4 at psu.edu               Dept. Fax:    814-863-6227

On 6/18/13 8:06 PM, Michael Brown wrote:
> On Tuesday 18 Jun 2013 22:29:44 Yadin Flammer wrote:
>> Unfortunately I continue to be baffled by the fact that dd apparently
>> does not work, or that all .usb files for gpxe and ipxe are defective in
>> some way.  No matter what I do, the usb drive remains blank.  I have
>> tried formatting FAT and EXT.  I have tried different .usb files.
>> Nothing.  The contents are never replaced if there are any before dd,
>> none are written if it's blank before dd. I'm at a loss.
> The .usb target definitely works.  I tested it just now.
> Please tell us exactly what you are doing, including verbatim copies of all
> commands and details of any modifcations you have made to the iPXE source
> code.
> Michael

More information about the ipxe-devel mailing list