[ipxe-devel] [gPXE] gpxe on USB or HD

LEVAI, Levente levail at aviatronic.hu
Fri Jun 14 06:34:43 UTC 2013

  Sorry for butting in, but please notice that Michael suggested

  dd if=bin/ipxe.usb of=/dev/sda

> ...the usb key results in a blank usb key (sdc1)...
I suspect you tried something like

dd if=bin/ipxe.usb of=/dev/sdc1

The right command were

dd if=bin/ipxe.usb of=/dev/sdc

(your usb pen drive is /dev/sdc, not /dev/sdc1, the
latter is the first partition on the pen drive)

If nothing works you may use grub4dos to chainload
ipxe (or even a gpxe, if that is your preference).

Hope this helps.

> As I have mentioned previously, using dd to clone the .usb file to the 
> usb key results in a blank usb key (sdc1).  On the off chance that the 
> entire contents were invisible for some reason, I tried to boot it 
> anyway, and simply got a black screen with nothing at all.  Per your 
> other email request, a little more detail:
> We have a Windows DHCP server which passes PXE to our WDS server.
> WDS has several boot and restore images available, which all work fine 
> when PXE booting a Dell system normally.
> The purpose of iPXE (previously gPXE) is to be able to PXE boot Mac 
> systems and use this restore functionality.
> This works perfectly when booting gPXE from CD made from the ISO.  As 
> USB is more convenient, and not all Mac systems have an optical drive, 
> I tried to get this working on USB.
> When attempting to use the iPXE ISO on CD, you get as far as choosing 
> the PXE boot image to boot from, and then the boot process (loading 
> windows progress bar at the bottom) simply never moves.  This 
> indicates an issue with iPXE that does not exist with gPXE.  I'm happy 
> to go with iPXE if gPXE is simply not going to be workable, but we may 
> need to actually get iPXE working on CD then before we move on to USB.
> When attempting to boot USB made via dd, you get nothing at all, just 
> black.  If you try this same USB on a Dell, you get non system disk or 
> disk error, cntl+alt+del to reboot.  Both behaviors are consistent 
> with a blank volume which indicates the files aren't invisible, they 
> just aren't there.  This would indicate to me either dd in Ubuntu 
> 12LTS is broken in some way, or the source .usb file is empty.  A 
> utility on Windows that is supposed to be able to open .usb files says 
> it's corrupt or the wrong format.
> As a fallback, since you can copy the contents of a bootable WinPE ISO 
> to a USB stick and simply boot it, I thought I'd try that with gPXE/iPXE.
> When attempting to boot a USB device made by copying the CD files to 
> USB, you get a black screen with GRUB and a flashing _ in the corner 
> and that's it, nothing further happens.  I'm guessing this might be 
> due to incorrect pointers for the device type since they are CD files 
> on USB?
> When attempting to boot a HD with the CD files copied to it, you're 
> told something like no system files found (I don't have it in front me 
> me this moment) which again I assume is some device pointer issue.
> Hope this helps flesh out the issues and guide some ideas what we 
> might try to get things working.
> Cheers,
> Yadin
> -------------------------------------------------------------------
>    Yadin Flammer - Systems Administrator
>    College of Arts&  Architecture, Penn State University
>    228 Borland Building              Office Phone: 814-865-0990
>    University Park, PA 16802         Dept. Phone:  814-865-1571
>    Email:yxf4 at psu.edu  <mailto:yxf4 at psu.edu>                Dept. Fax:    814-863-6227
> On 6/13/13 8:17 PM, Michael Brown wrote:
>> Yadin Flammer<yxf4 at psu.edu>  <mailto:yxf4 at psu.edu>  wrote:
>>> Thanks for the response.  I have tried ipxe and it also does not work.
>>> Trying to dd it to a drive under ubuntu 12 LTS results in a blank
>>> drive.  Copying the files from the ISO to the USB results in booting to
>>> a black screen with GRUB and a flashing cursor and nothing else.  I
>>> tried posting to the ipxe forums but they appear to not be working as
>>> no
>>> post happens and no error is given as to why.
>>> Any advice on getting a USB drive to work with ipxe, as well as getting
>>> the forums to work so I can reach a wider audience, are appreciated.
>>> Cheers,
>>> Yadin
>>> On 6/13/2013 1:01 PM, Michael Brown wrote:
>>>> On Thursday 13 Jun 2013 17:14:49 Yadin Flammer wrote:
>>>>> I've been trying to get gpxe to boot from a USB drive, and even an
>>>>> internal hard drive, but no luck.  Using the ISO for a CD works
>>>>> perfectly, but a USB key would be much more convenient.  The .usb
>>> and
>>>>> .dsk files that download appear to be corrupt every time as no
>>>>> application can open them (winimage says they are corrupt), or the
>>>>> contents when dd to a disk under linux are corrupt.  Copying the
>>>>> contents of the .iso to a USB drive or internal HD does not result
>>> in a
>>>>> bootable system regardless of the format or setup of the drive.
>>>>> Has anyone managed to make a bootable USB key or internal drive with
>>> the
>>>>> gpxe environment and if so precisely how?
>>>> gPXE has not been maintained for several years.  Please upgrade to
>>> iPXE, which
>>>> is the replacement for gPXE.
>>>> You won't be able to open the .usb image, since it doesn't contain a
>>>> filesystem.  It's a raw disk image; you need to transfer it to the
>>> USB key
>>>> using dd (or equivalent).  Be aware that this will erase all existing
>>> content
>>>> of the USB key.
>>>> Michael
>> Use dd to transfer the iPXE .usb image to the USB key, then boot from that USB key.  For example, assuming your USB key is /dev/sda, then use
>>    dd if=bin/ipxe.usb of=/dev/sda
>> (Warning: /dev/sda is probably your main system disk. Find out which device represents your USB key and use that instead.)
>> Forum posts by new users are moderated to eliminate spam, which is why yours hasn't appeared yet.
>> Michael
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ipxe.org/pipermail/ipxe-devel/attachments/20130614/c89e8475/attachment.htm>

More information about the ipxe-devel mailing list