[ipxe-devel] UEFI efi_image_exec path

Niket Kandya niketkandya at gmail.com
Mon Jul 29 21:20:58 UTC 2013


I was trying to chain boot an efi image.
My setup is all like traditional PXE with snponly.efi as the PXE file.

While chainloading an EFI file, I always fail at last_opened_snpdev() as it
internally tries to find a PCI SNP device which it does not find. Is the
problem here itself ??

Or what I understood that this can be the case as this is a software
interface with no PCI address. To fix that I tried installing the protocols
onto a new handle (initially NULL) and then loading the image, however the
image never finds any files to read. So I tried doing this on the
efi_image_handle itself. And this failed again with none of these protocols
even being found on the device handle of the new image. I also tried using
any efi_pci_device, but none is found.

Any suggestions??


Thanks and Regards,
Niket Kandya,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ipxe.org/pipermail/ipxe-devel/attachments/20130729/33eb63c6/attachment.htm>

More information about the ipxe-devel mailing list