[ipxe-devel] iPXE fails to fetch files via https - invalid argument and error 1c0dee02

Nicola Volpini Nicola.Volpini at kambi.com
Thu Jan 31 09:20:01 GMT 2013


On Wed 30 Jan 2013 06:04:15 PM CET, Michael Brown wrote:
> Please try the attached (untested) patch, which will try to work around this
> problem.  If the certificate chain is very large then you may still hit an out-
> of-memory error, which should have the new error number 310de806.

Hi Michael,

thanks for the prompt reply! The patch fixes the specific issue, great. 
Unfortunately I get another error now (not a memory one, apparently!). 
It's 0216e13c. According to the specific line:
"return -EACCES_WRONG_ISSUER."

This could well be an issue on our side... We're using a chain and I 
embedded the chain, the last certificate of the chain and the root.
I was looking for a way to enable some debugging of the TLS. Is there a 
flag I can change to discover more?

Thank you

--
Nicola Volpini
Infrastructure Operations
The information in this email is confidential and may be legally privileged.
If you are not the intended recipient, you must not read, use or disseminate that information
and upon reception, permanently delete the original and destroy any copies.
Although this email and any attachments are believed to be free of any virus
or any other defect which might affect any computer or IT system into which
they are received and opened, it is the responsibility of the recipient to
ensure that they are virus free and no responsibility is accepted by Kambi
for any loss or damage arising in any way from receipt or use thereof.


More information about the ipxe-devel mailing list