[ipxe-devel] building for use virtualbox

Mark Gollahon mgollahon at exacq.com
Mon Jan 28 16:25:37 GMT 2013


On Mon, Jan 28, 2013 at 11:00 AM, Andrew Bobulsky <rulerof at gmail.com> wrote:
> On Jan 28, 2013, at 10:10 AM, Mark Gollahon <mgollahon at exacq.com> wrote:
>
>> On Sun, Jan 27, 2013 at 7:00 AM,  <ipxe-devel-request at lists.ipxe.org> wrote:
>>>
>>> On 24.01.2013 18:09, Andrew Bobulsky wrote:
>>>> If you are indeed having build-related problems, I wouldn't be able to
>>>> help you much, but I wanted to write as I've experienced this before.
>>>> Virtualbox includes a version of iPXE that has very limited protocol
>>>> support, and it is the default PXE ROM in every vbox VM I have used.
>>>> If, for some reason, your attempt to inject the ROM into your
>>>> Virtualbox VM's configuration didn't work, it would load the built-in
>>>> version instead, and while you'd be loading iPXE (which would /look
>>>> /like a successful implementation, but of course is just the old,
>>>> built-in ROM loading).  That built-in iPXE splash screen looks like
>>>> this: http://i.imgur.com/gfVjURG.png
>>>
>>> If you use the vboxmanage command to replace the built-in pxe rom in
>>> vbox with the one built from the ipxe source you're most likely getting
>>> the bundled ipxe from vbox, not the one you compiled. I have tried a
>>> bunch of alternatives to make it load a custom ROM, but I've been
>>> unsuccessful so far. If you figure it out, please report back.
>>>
>>> -- Robin
>>
>> When I was building iPXE for VBox (a year ago now? check archives), I
>> had to get the binary down below about 56-58K before VBox would load
>> it.  Note that VBox docs say <64K but that never worked for me.
>>
>> Regards,
>> Mark
>
> Hello Mark,
>
> Did you use vboxmanage to switch the ROMs, and did non-working
> binaries result in VBox loading the built-in PXE ROM instead?  As
> opposed to refusing to boot, for example :)
>
> Cheers,
> Andrew Bobulsky

Yes, I used vboxmanage to switch the roms (all it did was mark the rom
for loading in the vbox vm config file).

When the ROM failed to load, VBox did fall back to the Intel UNDI rom
load (that's how I knew it didn't load and stopped the VM so I could
try a new iPXE rom).  There was also some cryptic lines in the VBox VM
log about why it failed.  Once I got things running, I then switched
over to the virtio iPXE load instead of the Intel (the virtio device
is more efficient...).

I will say that I had to cut aLOT of stuff out of iPXE to get it to
run in the VBox environment.  I don't remember everything I cut and my
dev files are on my laptop at home so I can't go and look at the
moment.  (In fact, I think I just deleted them, as they had been
taking up space for over a year now....)

Also, there was some talk on the VBox developers' list awhile back on
relaxing the 56/58K ROM size limit, but I don't know what came of it.

Finally, I will say that my PXE was at the *end* of the BIOS boot list
instead of first or somewhere in the middle.

Hope this helps!

Mark


More information about the ipxe-devel mailing list