[ipxe-devel] FATAL: int13_eltorito: call with AX=4d00. Please report

Robin Smidsrød robin at smidsrod.no
Thu Jan 3 08:47:30 GMT 2013


On 03.01.2013 03:08, Michael Brown wrote:
> On Thursday 03 Jan 2013 01:36:30 Shao Miller wrote:
>> Sorry, I wasn't paying close enough attention.  I actually don't fully
>> understand how int13_load_eltorito() can ever be expected to work
>> without iPXE already driving the optical disc drive using, for example,
>> an ATAPI driver. :)
> 
> The code in int13_load_eltorito() is intended to allow iPXE to boot from one 
> of its own SAN drives.  The fact that "sanboot --drive XX" can be (ab)used to 
> boot from a local disk is just an unofficial side benefit.
> 
> One possible hackish workaround for this particular scenario would be to SAN-
> boot from an ISO which matches the local CD-ROM.  The SAN boot would provide 
> access via INT 13, and the loaded OS would find the (identical) local CD-ROM 
> after starting the kernel.

Interesting. I tried it out, and it failed also, but with a twist. First
of all I had to hook the iscsi volume as drive 0x81 (0x80 just wouldn't
do) and the DVD as drive 0x80. If I didn't do that I just got an error
message that the BCD was unreadable (0xc000000e). When I booted the
installer as drive 0x80 (with the DVD also in the local CDROM) it went
quite a lot further, and then it failed with 0xc00000e9 (unexpected I/O
error). I'm starting to wonder if it actually has problems reading the
data either from the web server or the local drive. Anyone seen this
before? My Apache configuration is the same as the one that has always
worked for other netbooting.

> Unless I'm missing something, it's probably a better idea to just use wimboot.

I was actually trying (again) to boot Windows 7 off iSCSI, and I was
testing things out in VirtualBox. I was using wimboot, and my iscsi
volume never showed up in diskpart, so I was trying to fall back to a
simpler setup with just hooking the iscsi volume and booting a local
DVD. I guess I should've learned by now that when things fail on virtual
I should test on physical hardware instead of going for a simpler setup...

Can anyone confirm if they've been able to install Windows 7 on an iSCSI
volume INSIDE VirtualBox?

And from what you say, I guess there is no point in applying the patch
when it just isn't going to work. It might be worthwhile to add the
error message from VirtualBox to the troubleshooting section of the
sanboot command, in case other people encounter it and go googling for
help. It should just state that sanboot --drive 0xXX will not work on
VirtualBox (until they fix that issue with the FATAL error).

-- Robin



More information about the ipxe-devel mailing list