[ipxe-devel] FATAL: int13_eltorito: call with AX=4d00. Please report

Steve Cross hairlesshobo at stevecross.org
Wed Jan 2 13:00:25 UTC 2013

I ran into a LOT of problems when I was trying out iSCSI installations
in VirtualBox. From what it seems, once VirtualBox loads the PXE rom,
it fails to pass control back over to anything else afterwards and it
gives you that error message. I remember reading some other things
online about it as well suggesting that it is a bug in the VirtualBox
PXE implementation. The best thing I can recommend is to setup a WinPE
on the network and using wimboot, boot to the PE and then launch the
setup.exe from there. One other thing to keep in mind, once you boot
the PE, you can only install a Windows image of the same architecture,
so if you plan to install box x86 and x64 Windows images using iSCSI,
you will have to have a WinPE for both 32 and 64 bit.

If you need any help setting up the the WinPE, try checking out
http://ipxe.org/howto/winpe first and then there is also a lot on the
internet that explains how to create a WinPE as well. By the way, I
have only tested network installs to iSCSI using the Windows AIK
(WinPE 3.0 aka. Windows 7 WinPE). I have not used the Windows ADK
(Windows 8 version) of the WinPE.

Hope this helps in some way!


On Wed, Jan 2, 2013 at 4:41 AM, Shao Miller <sha0.miller at gmail.com> wrote:
> On 1/2/2013 02:30, Robin Smidsrød wrote:
>> On 02.01.2013 01:23, Shao Miller wrote:
>>> On 1/1/2013 15:18, Robin Smidsrød wrote:
>>>> Anyone seen this before?
>>>> https://dl.dropbox.com/u/354628/iPXE%20sanboot%20issue%202013-01-01.png
>>> I'm pretty sure that this is from VirtualBox' BIOS.  Does it give the
>>> same error message when you boot the DVD without any iPXE involvement?
>> Booting the Windows 7 DVD inside vbox directly works as intended. No
>> error messages appear.
>>> ETDump can only be expected to give useful results if the CD/DVD was
>>> actually booted.
>> Very good point. I guess I'll have to put it inside an ISO file and boot
>> _that_ to actually find the identifiers I'm looking for...
> It can be handy to boot a minimal ISOLINUX .ISO with chain.c32 to chain
> either the HDD or a floppy; that way the El Torito emulation is started (for
> ETDump, ETTool, ElTorito.sys, etc.) but you needn't bother with more than a
> one-time mkisofs invocation.
> Anyway, since it's working without iPXE, perhaps the iPXE INT 0x13 hook has
> a bug where the AH register is being incremented.  AH=0x4D means "Return
> Boot Catalog," but if it was an accidental increment, it might've been
> AH=0x4C, which is "Initiate Disk Emulation & Boot," which makes a whole lot
> of sense for the scenario you've described.
> - Shao Miller
> _______________________________________________
> ipxe-devel mailing list
> ipxe-devel at lists.ipxe.org
> https://lists.ipxe.org/mailman/listinfo.cgi/ipxe-devel

More information about the ipxe-devel mailing list