[ipxe-devel] EFI binaries won't load under iPXE

James A. Peltier jpeltier at sfu.ca
Tue Apr 9 20:25:43 UTC 2013

Further to the discussion which I clearly misunderstood.  See 	Re: [ipxe-devel] Regression with commit fc87adb46c1395b09302085e9d15fcd8ab3c31fe - [efi] Expose downloaded images via EFI_SIMPLE_FILE_SYSTEM_PROTOCOL on IMAGE_EFI

I am unable to load an EFI binary when using an EFI version of iPXE.  What incantation is required for this to work?  I've tried

  chain ${centos6-base}/EFI/BOOT/BOOTX64.efi || goto failed

which ends up with 

  "Could not boot: No such device"

I've also tried the following and it didn't work

${centos6-base}/EFI/BOOT/BOOTX64.efi || goto failed
boot || goto failed

This is my first time working with iPXE and (U)EFI based machines so any help would be greatly appreciated.

James A. Peltier
Manager, IT Services - Research Computing Group
Simon Fraser University - Burnaby Campus
Phone   : 778-782-6573
Fax     : 778-782-3045
E-Mail  : jpeltier at sfu.ca
Website : http://www.sfu.ca/itservices

“A successful person is one who can lay a solid foundation from the bricks others have thrown at them.” -David Brinkley via Luke Shaw

More information about the ipxe-devel mailing list