[ipxe-devel] Realtek r8169 (10ec8168.rom) breaks download everytime at 47%

Joshua C. joshuacov at googlemail.com
Thu Jan 12 00:07:23 UTC 2012

> Time isn't the issue.  The "Press Ctrl-B to configure iPXE prompt" is displayed
> during POST.  If the user presses Ctrl-B at this point, then POST is never
> completed and the system memory map may never be fully constructed.
> (Note that this isn't the same as the "Press Ctrl-B for the iPXE command line"
> prompt, which is perfectly safe to use.)

I'm not sure when I press ctrl+B. I know that I see the message but I
thought it was to enter the command line for ipxe.

> Try using a non-ROM image first, such as ipxe.iso, to eliminate any possible
> problems due to early BIOS initialisation issues.
> Michael

I tried it with the 10ec8168.lkrn. Everything is fine with it and no
break ups occured. I used the same file for testing and tried
downloading it from different servers. No problems at all. After this
I flashed the 10ec8168.rom into the bios and started observing those
strange connection break ups at exactly the same time.

I also came to the conclusion that this has something to do with the
memory initialization but I thought since the lrkn image loads after
the boot loader which loads after the bios has completely initilized,
then it shouldn't have any problems. The rom image loades before the
bios has finished and therefore this could be the culprit. I was
thinking if I can flash the lrkn as a rom part into the bios but based
on the above conclusion I thought it should work (I think the lkrn
needs the fully initilized system to load???)

Any ideas how to help with debuging this? Could this be a problem of
the motherboard (msi p67a-gd65)?


More information about the ipxe-devel mailing list