[ipxe-devel] Realtek r8169 (10ec8168.rom) breaks download everytime at 47%

Joshua C. joshuacov at googlemail.com
Tue Jan 10 23:52:24 UTC 2012

2012/1/10 Michael Brown <mbrown at fensystems.co.uk>
> On Sunday 08 Jan 2012 15:39:46 Joshua C. wrote:
> > as the title says I compiled the latest git code (git-date: 07.01.2012) for
> > my card (10ec:8168) and successfully inserted it in my bios. I activated
> > all features in general.h (even wireless, but no debug options and no
> > serial) and the rom image grew up to about 77kb. I flashed the modified
> > bios and tested it trying to install the latest fedora16. iPXE started
> > successfully but everytime I try to download the file
> > http://download.fedora.redhat.com/pub/fedora/linux/releases/16/Fedora/x86_6
> > 4/os/isolinux/initrd.imgthe connection breaks exactly at 47%.
> >
> > First I download the vmlinuz with "kernel
> > http://download.fedora.redhat.com/pub/fedora/linux/releases/16/Fedora/x86_6
> > 4/os/isolinux/vmlinuz" and it works fine. This file is about 4mb. The when
> > trying to doanload the
> > http://download.fedora.redhat.com/pub/fedora/linux/releases/16/Fedora/x86_
> > 64/os/isolinux/initrd.imgwhich is about 129mb, the connection breaks at
> > exactly 47% and the orange color on the ethernet connector stops blinking.
> > Can some take a look at this? Is there any memory limit (up to about 65Mb
> > = 4mb + 47%x129mb) the ipxe can use?
> >
> > What I noticed during my tests is that the connection is extremely slow.
> > When I boot with 10ec8168.lkrn then everything works fine (no breaks at
> > 47%). With linux I reach the maximum speed of my connection (about 2,3mb/s)
> > and the aforementioned files download for about 1,5min. With 10ec8168.rom
> > it takes about 2 min only for the vmlinuz about about 6min for initrd.img
> > before reaching 47% and breaking down. Why is that? in both cases I use the
> > r8169 driver.
> Does the problem occur at the same point if you download initrd.img from a
> local web server on your LAN?

I haven't tried this yet. Up to now I used different http servers in
the internet with one and the same result: drop@ 47%.

> Are you entering iPXE when the "Press Ctrl-B to configure iPXE" message is
> displayed (rather than waiting for the BIOS to attempt a boot via iPXE)?  If
> so, then that might be your problem.  (At the "configure iPXE" stage, the BIOS
> may not yet have created the full system memory map, which can cause various
> strange issues.)
> Michael

That's an interesting point. Actually I'm pressing Ctrl-B to enter
into the ipxe. I've compiled the default git code and the system
doesn't have any boot server set. That's the reason I manually point
it to the http servers...

I dont't know how the code initialize the system memory but I think it
should have enough time to do so. The drop out happens after apx 8-9
mins after system start. This should be enough, shouldn't it? If this
is really the culprit of the problem, then maybe there should be a way
to handle the driver an updated system memory map after the system has
finished the initialization process.

What about the download speed? Do you have any idea why it's so slow
compared to the speed when running linux and/or windows?


More information about the ipxe-devel mailing list