[ipxe-devel] lkrn command line issues

Michael Brown mbrown at fensystems.co.uk
Tue Jan 10 19:40:39 UTC 2012

On Wednesday 04 Jan 2012 17:25:41 Dave Hansen wrote:
> I was trying the lkrn command-line on some different hardware than I
> normally use, and I'm seeing some issues.  I seem to just get jibberish
> instead of the command-line that I passed in:
> cmdline_phys: 99000
> cmdline_user: 80b28f90
> cmdline_user len: 2
> cmdline[0]: 0x13 ""
> cmdline[1]: 0x00 ""
> It seems limited to one system.  The command-line still works on some
> other systems and in QEMU virtual machines.  I checked to see if it was
> a regression, and found out that lkrn command-line support has never
> worked on this hardware.  I tried loading from both "legacy" GRUB and
> GRUB2, but they have the same failure mode.  Any thoughts on how to
> debug this further?

Is it possible that the cmdline is being overwritten by iPXE when it installs 
its base-memory portions?  What are the values of rm_cs and rm_ds at the point 
of calling cmdline_init()?


More information about the ipxe-devel mailing list