[ipxe-devel] Using iPXE to chain load Windows PE shows blank screenin Dell notebook

Tal Aloni tal.aloni.il at gmail.com
Tue Nov 29 12:46:50 UTC 2011

I have tested the Dell Latitude E6400 and E6410 on the past,
IIRC at least one of them is showing the described issues even when booting Windows PE from tftp, this issue has nothing to do with iPXE.

Tal Aloni
  ----- Original Message ----- 
  From: Chee-Yang Chau 
  To: ipxe-devel at lists.ipxe.org 
  Sent: Tuesday, November 29, 2011 2:38 PM
  Subject: [ipxe-devel] Using iPXE to chain load Windows PE shows blank screenin Dell notebook


  I have both PC and Dell notebook in my LAN environment.  Both PC and Dell notebook supports PXE boot.

  I attempt to chain boot into Windows PE with SanBoot iscsi target:

  1. DHCP
  2. undionly.kpxe
  3. Press Ctrl-B to iPXE command  line
  4. set keep-san 1 
  5. set skip-san-boot 1
  6. sanboot iscsi-target
  7. chain tftp://

  Boot PC using above steps does boot into Windows PE environment with iscsi target available for Windows setup.

  However, Dell notebook using same steps boot the Windows PE too, but it doesn't show the GUI screen as what PC does.   I have tried 2 dell notebook and both giving same result.  My Windows PE image will show a cmd windows after loading the Windows PE.  The dell notebook doesn't show anything and screen just blank.  I try to type exit and press enter, the notebook will reboot.  I feel it did boot into Windows PE but doesn't show the GUI screen.

  I then try another steps using PXE Linux:

  1. DHCP
  2. pxelinux.0
  3. show menu "pxelinux.cfg/default"
  4. kernel windows.pe/pxeboot.0

  Both PC and Dell notebooks boot into Windows PE GUI environment and I can see the GUI screen for notebook as well.  

  Both scenarios using same WinPE image.  

  What could cause the notebook using iPXE to chain load WinPE shows blank after booting?

  Thank you.

  Best regards,
  Chau Chee Yang


  ipxe-devel mailing list
  ipxe-devel at lists.ipxe.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ipxe.org/pipermail/ipxe-devel/attachments/20111129/563c40f3/attachment.htm>

More information about the ipxe-devel mailing list