[ipxe-devel] VirtualBox WDS Issues

Clifroy Henry buysomesocks at gmail.com
Thu Nov 24 21:16:13 UTC 2011

I've now moved the initiator to an physical device and have noted some
things. One device had a Broadcom based NIC and the other an Intel. On
initial boot of the Broadcom it hung up while trying to connect to the
target and gave me the same error as the VM. I switched to the Intel NIC
and it booted fine but then I got "WdsClient: An error occurred while
obtaining an IP address from the dhcp server......." but ipconfig shows a
valid IP.

I switched back to the Broadcom NIC, booted up and it got to the the
install prompts just fine. That is when I noticed that I forgot to
configure option 17 for the Broadcom MAC address. I removed option 17 from
the Intel reservation and it booted to the install prompts as well.

I tried to manually hook into the target, which works, and tftp the WDS
files but that results in the same DHCP error as above.

Googling the issue seems to come up with a resolution of enabling STP on my
switch but my switch is unmanaged. I can see when the link goes down and
comes back up on the Intel machine while the installation manager is
booting. I even went so far as to remove the switch and connect the VM host
and the initiator together but still no success.

On Tue, Nov 22, 2011 at 3:02 AM, Clifroy Henry <buysomesocks at gmail.com>wrote:

> I have a system of virtual machines setup on an internal network with the
> VB dhcp server disabled.
> #1 is my firewall with one port bridged to the interface on the host and
> the other interface on the internal network. DHCP is disabled and relayed
> to #2 Which is a Windows 2008 R2 Server managing WDS. I have the DHCP
> options configured to point to my #3 Debian target and #4 Is the initiator.
> I have been forced to use ipxe.iso as all my previous efforts of
> chainloading undionly.kpxe then booting wdsnbp.com have failed with some
> weird WDS error which after being in contact with Michael Brown over IRC I
> still was not able to resolve.
> When using any of the Intel NICs in VB after displaying the Root Path, it
> pauses for about 5 seconds or so and then shows "Could not open SAN device:
> Connection timed out (http://ipxe.org/4c0a6035)
> No more network devices"
> The strange thing is if I change to any of the AMD PCNET NICs it boots
> fine until it complains that it couldn't find a driver in the image.
> I'm at my whits end so if anyone could spare some insight it would be much
> appreciated. Thank you.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ipxe.org/pipermail/ipxe-devel/attachments/20111124/4c14d207/attachment.htm>

More information about the ipxe-devel mailing list