[ipxe-devel] ipxe.lkrn cmd line failures, but initrd success

Michael Brown mbrown at fensystems.co.uk
Sun Nov 20 16:04:06 UTC 2011

On Friday 18 Nov 2011 14:27:03 Kenneth MacDonald wrote:
> However, today I tried this on two other computers (Dell Optiplex 780
> and 790) and neither worked.  I had been developing this on an HP Compaq
> dc7900.  It appeared GRUB wasn't passing iPXE the command line, or iPXE
> wasn't picking it up.  I tried both USB pen drive and hard disk drive
> installs of GRUB (grub-0.97-70.el6) and got the same behaviour in both.
> So, I was excited to see the new intrd functionality added recently
> (https://git.ipxe.org/ipxe.git/commit/27fdb9557266eaaadfb39a2eddfb06d2aade9
> 661), compiled ipxe.lkrn again today and found that the initrd worked a
> charm.  Exact same script, just copied from the previous GRUB kernel
> command line and placed in the initrd plain text file.

Glad that the initrd functionality worked for you!  If you have a moment, 
could you try the grub+command line approach with DEBUG=cmdline to see if it 
shows anything useful?



More information about the ipxe-devel mailing list