[ipxe-devel] compile ipxe under cygmin

Michael Brown mbrown at fensystems.co.uk
Wed Jun 29 11:54:30 BST 2011


On Wednesday 29 Jun 2011 06:19:11 zhengwei wrote:
> I have been using cygwin to compile ipxe, but I failed and got this error:
> 
> cid:image001.png at 01CC365E.5ABB45B0
> 
>    What's wrong with it? The Gcc is too old?

Looks like a bug in some older versions of gcc:

  http://gcc.gnu.org/bugzilla/show_bug.cgi?id=18553

Should be worked around in the latest iPXE tree:

  http://git.ipxe.org/ipxe.git/commitdiff/95d82bb

Thanks!

Michael


More information about the ipxe-devel mailing list